Posts

Aelia - Product update badge

WooCommerce PayPal Standard Multi-Account 1.2.3.150610

PayPal Multi-Account for WooCommerce – What’s new

Our PayPal Standard Multi-Account Gateway for WooCommerce has been updated to version 1.2.3.150610. This update brings the following improvements and fixes:

  • Fixed bug in IPN handling in WooCommerce 2.3.10. The bug was caused by incorrect references in base WC_Gateway_Paypal_IPN_Handler class, which caused the PayPal merchant email validation to fail in some circumstances. Ref. https://github.com/woothemes/woocommerce/pull/8348.

How to get latest version

New customers

Simply place your order and you will get the latest version.

Existing customers

You should be able to download the updated file using the link you received with your order. If the link doesn’t work, please contact Support to receive the latest version. Thanks.

Aelia - Product update badge

WooCommerce PayPal Standard Multi-Account 1.2.2.150519

PayPal Multi-Account for WooCommerce – What’s new

Our PayPal Standard Multi-Account Gateway for WooCommerce has been updated to version 1.2.2.150519. This update brings the following improvements and fixes:

  • Improved support for Subscriptions. The plugin can now alter the API keys used by the Subscriptions plugin depending on the currency used to buy the subscription.
  • Set requirements to WooCommerce 2.1.x, 2.2.x or 2.3.8 or later. The plugin cannot work properly with WooCommerce 2.3.0 to 2.3.7 due to some issues in the core.
  • Imported logic to use a single logger for all PayPal Standard classes in WooCommerce 2.3. Ref. https://github.com/woothemes/woocommerce/commit/33d94aaea46137a0d8366e9033e6bebd218333cc.

How to get latest version

New customers

Simply place your order and you will get the latest version.

Existing customers

You should be able to download the updated file using the link you received with your order. If the link doesn’t work, please contact Support to receive the latest version. Thanks.

Aelia - New product badge

WooCommerce PayPal Standard Multi-Account v1.2.0.150506

PayPal Multi-Account for WooCommerce – What’s new

Our PayPal Standard Multi-Account Gateway for WooCommerce has been updated to version 1.2.0.150506. This update brings the following improvements and fixes:

  • Added support for PayPal API settings in multiple currencies. The admin user interface has been extended and it’s now possible to specify API settings for each of the available currencies. This feature requires WooCommerce 2.2 or later.
  • Added support for refunds. Refunds rely on the API settings, which can now be saved on a per-currency basis.

How to get latest version

New customers

Simply place your order and you will get the latest version.

Existing customers

You should be able to download the updated file using the link you received with your order. If the link doesn’t work, please contact Support to receive the latest version. Thanks.

Aelia - New product badge

WooCommerce PayPal Standard Multi-Account v1.1.2.150422

PayPal Multi-Account for WooCommerce – What’s new

Our PayPal Standard Multi-Account Gateway for WooCommerce has been updated to version 1.1.2.150422. This update brings the following improvements and fixes:

  • Added support for WooCommerce 2.3. In the latest version of WooCommerce, the PayPal gateway has been completely replaced by a new version, which was designed not to be extensible. We submitted a fix to the WooCommerce team on the 19th of March, but, although it was accepted, there is no plan to publish it until WooCommerce 2.4 is released. This poses a limitation to the extensibility of the PayPal gateway.
    We would not be able to wait several months, until our fixes become public, therefore we decided to rewrite the PayPal gateway from scratch, so that it can work around WooCommerce 2.3 limitations.

How to get latest version

New customers

Simply place your order and you will get the latest version.

Existing customers

You should be able to download the updated file using the link you received with your order. If the link doesn’t work, please contact Support to receive the latest version. Thanks.

We strongly recommend to remove the existing PayPal Multi-account plugin before installing the latest version, as the new plugin has a different architecture.